問題:「保管ダイアログの取得に失敗しました」
このメッセージは、Web Clientを開いたときに表示されることがあります。
エラーメッセージ
[HttpWebRequest_WebException_RemoteServer]

引数が見つかりません:NotFound
デバッグ・リソースの文字列が見つかりません。多くの場合、キーと引数は問題を診断するのに十分な情報を提供します。http://go.microsoft.com/fwlink/?linkid=106663&Version=4.0.60531.0&File=System.Windows.dll&Key=HttpWebRequest_WebException_RemoteServer を参照のこと。
そして
[HttpWebRequest_WebException_RemoteServer]
引数:NotFound
デバッグ・リソースの文字列は利用できません。多くの場合、キーと引数は問題を診断するのに十分な情報を提供します。
http://go.microsoft.com/fwlink/?linkid=106663&Version=4.0.60531.0&File=System.Windows.dll&Key=HttpWebRequest_WebException_RemoteServerを参照のこと。
原因:
これらのエラー メッセージは、WCF サービス WebBasketsWCF.svc にアクセスできないために発生します。
解決方法:
原因を特定するには、ブラウザで次のリンクを開いてください:
http:////DocuWare/Services/WebBasketsWCF.svc
例:http://localhost/DWWebClient/DocuWare/Services/WebBasketsWCF.svc
そこに表示されているメッセージを DocuWare サポートに連絡してください。
ほとんどの場合、IIS Managerのディレクトリ.DWWebClientの認証設定(匿名またはWindows)が不足しています。
問題:"Error rendering document"
Web Clientでドキュメントをレンダリングするときに、このメッセージが表示されることがあります。
エラーメッセージ:
http://localhost:9009/DWImagingに接続できませんでした 。Tcpエラーコード10061:ターゲットマシンがアクティブに拒否したため、接続できませんでした。
原因
- DocuWare Imaging Serverがインストールされていないか、起動していないか、またはアクセスできません。
- ポート9009がファイアウォールでブロックされている可能性があります。
問題:
http://localhost:9009/DWImaging へのHTTP応答を受信中にエラーが発生しました。これは、サービスエンドポイントバインディングがHTTPプロトコルを使用していないことが原因である可能性があります。
これは、HTTPリクエストコンテキストがサーバーによって中止されたことが原因である可能性もあります(サービスがシャットダウンしたことが原因である可能性があります)。詳細はサーバーログを参照してください。
原因:
別のアプリケーションがこのポートで実行されている。
解決策:
どのプロセスが現在このポートを使用しているかを調べるには、コマンドラインに"netstat -ano "と入力してください。対応するプロセスは、PIDを使ってTask Managerで見つけることができる。
問題:「指定されたパスまたはファイル名が長すぎます」
このメッセージは文書を開くときに表示されることがある。
エラーメッセージ:
完全修飾名は260文字未満、パスは248文字未満でなければなりません。
原因:
Windowsでは、完全なファイル名には制限があります。パスとファイル名は260文字以下でなければなりません。Web Clientでは、これは次のように構成されます:Webインスタンスの一時ディレクトリのパスとドキュメントのファイル名。
解決策:
これを短くするには、一時ディレクトリを別の短いパスで定義します。また、別のインデックスフィールドをDocuWareのドキュメント名として記述することもできます。
問題:"Parser Exception"
検索を開始するときにこのメッセージが表示されることがあります。
原因:
これは一般的なメッセージで、検索語を正しく解釈できなかったことを示しています。これは特殊文字、例えば"("や") "を検索する場合によく起こります。
解決方法:
特殊文字は、斜体でマスクする必要があります。
問題:「これはDocuWareの署名された言語バージョンではありません」
このメッセージは、Web Clientにログオンした後に表示されることがあります。
Cause:
The language file used under "...\DocuWare\Web Modules\WebClient Central\DocuWare\Languages\Strings\"(5.1b ...\DocuWare\Web Client Server\Web Common\DocuWare\Languages\Strings\) has been modified or is corrupted.
解決方法:
言語ファイルを交換する必要がある。
問題:"Object reference not set to an instance of an object"
このメッセージが Web Client に表示されることがある。
解決方法:
Web Clientの一時ディレクトリのエラーログディレクトリのログを確認してください。ほとんどの場合、設定エラーの結論は対応するログエントリによって示されます。これは、検索ダイアログに保管されている結果リストが公開されていないか、ユーザーに割り当てられていないために発生します。
問題:ターミナルサーバーまたはリモートデスクトップセッションで、ドキュメントを開くときに赤色の十字が表示される
:ターミナルサーバーまたはリモートデスクトップセッションの場合: ドキュメントを開くときに赤い十字が表示されます。
原因:
表示に必要な色深度が不足しています。Web Clientでドキュメントを表示するには、最低16ビットの色深度が必須です。
問題:「http://tempuri.org/dwimaging/openfilecreator 受信側で処理できません」
ドキュメントを開くときに、このメッセージが表示されることがあります。
エラーメッセージ
EndpointDispatcherのContractFilterの不一致によるものです。
原因:
DocuWare Imaging ServerのバージョンステータスがWeb Client Serverと同じではありません。
解決方法:
Imaging ServerのService Pack/更新がインストールされているか確認してください。必要であれば、再インストールしてください。
問題:ドキュメントを電子メールとして送信できない(Click Once)
解決方法:多くの場合、Click Once のキャッシュは、Web Client Server と同じです:
- 多くの場合、該当するシステムの Click Once キャッシュは、次のコマンドで空にすることができます:
rundll32 %windir%system32 dfshim.dll CleanOnlineAppCache - 401エラーメッセージが表示される場合は、IISマネージャの認証設定を確認してください。ここで、「Apps」ディレクトリに対して匿名認証のみが有効になっていることを確認してください。
- 407エラーメッセージが表示される場合は、プロキシサーバーが使用されています。Webサーバーをプロキシの使用から除外してください。
ご注意:この記事は英語からの翻訳です。この記事に含まれる情報は、オリジナルの英語版製品に基づくものです。翻訳版の記事で使用されている文法などには、細かい誤りがある場合があります。翻訳の正確さを完全に保証することは出来かねますが、ほとんどの場合、十分な情報が得られると思われます。万が一、疑問が生じた場合は、英語版の記事に切り替えてご覧ください。
