ビュー:

動作:
DocuWare Version 6.6、6.7、6.8にアップデート後、フルテキストが動作しない!

原因:
古いDocuWare VersionからDocuWare Version 6.6へのアップデートを数回に分けて直接行った場合、フルテキストテーブルのアップデート前処理が完了しないことがあります。これにより、DocuWare Version 6.6でフルテキストが利用できなくなる可能性があります。

Catalinaのログでは、Fulltext Serverパスに以下のメッセージが記録されています:

org.apache.solr.common.SolrException:Error parsing fieldname: Expected identifier at pos 0 str='@rowtype, DWDOCID_i, DOCID_s'.

dwdata.Task_Processテーブルには、タスク1プロセス(アップグレード・タスク)があり、TaskSettings列に以下の値が表示されています。

FCUpgradeTaskSettingsnextInProcessDocId="2147483646 "UpgradeFrom="OlderDocuWareVersion"]。

古いDocuWareバージョンからタスク1をアップグレードします。

また、関連するファイルキャビネットに、フルテキスト検索が機能しない古いフルテキストテーブルが存在することがあります。たとえば、filecabinet_FTD、filecabinet_FTDO、filecabinet_FTI、filecabinet_FTMのようなテーブルです。

すべてのテキスト・タブ

解決策
以下の手順を実行する前に、dwdataデータベースの実際のバックアップを作成してください!

ファイルキャビネットの古いフルテキストテーブル(filecabinet_FTD、filecabinet_FTDO、filecabinet_FTI、filecabinet_FTM)を削除してください。

古いバージョンのフルテキストテーブルを更新する必要がないため、dwdata.Task_Processテーブルからタスク1の行を削除します。DocuWareバージョン6.6で使用される新しいフルテキストテーブルは、filecabinet_PAGEテーブルとfilecabinet_SECTテーブルです。

Content Serverを再起動し、フルテキストデータを新しく処理できるように、関連するファイルキャビネットのフルテキストをリセットします。


ご注意:この記事は英語からの翻訳です。この記事に含まれる情報は、オリジナルの英語版製品に基づくものです。翻訳版の記事で使用されている文法などには、細かい誤りがある場合があります。翻訳の正確さを完全に保証することは出来かねますが、ほとんどの場合、十分な情報が得られると思われます。万が一、疑問が生じた場合は、英語版の記事に切り替えてご覧ください。